تست نفوذ و امنیت
موضوعات داغ

آموزش نصب متاسپلویت در اندروید

متاسپلویت یک فریمورک و بستری برای توسعه اکسپلویت و کد های مخرب می‌باشد.

این فریمورک شامل بیش از هزاران اکسپلویت و ابزار های جانبی برای تست نفوذ نفوذ و امنیت می‌باشد.

وجود امکانات متعدد در این ابزار باعث بدل شدن Metasploit به یک ابزار اصلی در دنیای تست نفوذ شده است.

این ابزار توسط تیم و گروه امنیتی رپید سون یا همان Rapid 7 توسعه و طراحی شده است.

این ابزار قابلیت نصب به صورت کراس پلتفرم را دارا می‌باشد و در سیستم عامل های مختلف از جمله گنو/لینوکس و ویندوز قابلیت نصب دارد. اما نصب آن تنها به این دو سیستم محدود نمی‌شود. شما می توانید این ابزار تست نفوذ را بر روی تلفن همراه خود به راحتی نیز نصب و اجرا کنید.

 

شما در این آموزش نحوه نصب این ابزار را در تلفن هوشمند اندرویدی خود یاد خواهید گرفت.

برای نصب این ابزار هیچ نیازی به روت بدون تلفن همراه خود ندارید! تنها داشتن یک گوشی اندرویدی با ورژن Android +5.0 و حدود یک گیگابایت حافظه برای نصب و نگهداری فایل های متاسپلویت کافی است.

 

 

نصب متاسپلویت در Termux:

برای نصب این ابزار در تلفن همراه خود کافیست مراحل زیر را به ترتیب دنبال کنید.

 

1. نصب برنامه Termux در تلفن همراه خود، برای دانلود ترموکس از گوگل پلی استور اینجا کلیک کنید.

 

2. بعد از نصب برنامه آن را باز کرده و مخازن غیر پایدار ترموکس را توسط کد زیر اضافه کنید:

pkg upgrade
pkg install unstable-repo

 

3. حالا با دستور زیر می توانید متاسپلویت را بر روی تلفن خود نصب نمایید:

pkg install metasploit

 

حال هر زمان که نیاز به اجرا کردن این ابزار داشتید کافی است تا دستور msfconsole را در ترموکس وارد نموده تا ابزار برای شما اجرا گردد.

 

mehrunex

دانشجوی رشته فناوری اطلاعات و علاقمند به مباحث برنامه نویسی، امنیت اطلاعات، الکترونیک، رایانش کوانتومی، فیزیک، نجوم و بیوالکترونیک

‫11 دیدگاه ها

  1. با سلام ادب احترام.پیش نیاز نصب و به کار اندازی ابزارهای روی نرم افزار ترموکس اندروید چیست؟wifiete.wifi hacker ht wps braker air crack ng easy hack hijacker lazy mux را بعد از این که از سایت گیت هاب روی ترموکس ریختیم چگونه استفاده کنیم؟
    تدریس کار با نرم افزار ترموکس اندروید چگونه ممکن است؟
    با سپاس از وقتی که در اختیارم میگذارید.
    امیر آزاد
    0935*******

    1. با سلام
      برای اجرای هر یک از ابزار ها باید نحوه کارکرد ابزار، زبان برنامه نویسی آن ابزار و… در نظر گرفته شود و به همین دلیل نمی توان آموزش جامعی در سایت قرار داد.
      اما در حال حاظر در حال گردآوری مطالب برای ابزار های معروف هستیم و بزودی در سایت منتشر خواهیم کرد.

  2. آیا امکان نصب شایر ابزار های لینوکس تو ترموکس وجود دارد؟

  3. سلام ببخشید من مرحله اول رو که انجام میدم در مرحمله دوم یعنی pkg install metasploit ارور پکیج پیدا نشد برای من نمایش داده میشه و من یه نگاه به لیست پیکج ها انداختم همچین پکیجی به نام metasploit در لیست پکیج های من وجود نداره لطفا راهنمایی کنید

    1. ابتدا از نصب شدن unstable-repo اطمینان حاصل کنید بعد اقدام به نصب متاسپلویت کنید

      1. با سلام .
        کاملا نصب میشه ولی در مرحلهpkg install metasploit ارور میده .
        لطفاً راهنمایی کنید.

        1. درود احتمالا باید مشکلی در مخازن غیر پایدار یا همان Unstable Repo وجود داشته باشد. یکبار با استفاده از pkg uninstall unstable-repo اقدام به پاک نمودن این پکیج و سپس نصب مجدد آن کنید.
          قبل از نصب Metasploit باید از نصب Unstable Repo اطمینان پیدا کنید. برای اینکار از نرم افزار های تغییر IP استفاده نموده و قبل از شروع کار یکبار دستور pkg upgrade را وارد کرده و مراحل این مطلب را مجددا انجام دهید.
          بجای pkg هم می توانید از مدیریت بسته apt استفاده نمایید و دستورات زیر را وارد نمایید:
          apt update
          apt upgrade
          apt install unstable-repo
          apt install metasploit

  4. باسلام
    من تویه نصبunstable-repo در آخر ارور میده و این پیغام رو میفرسته
    E: Unable to locate package unstable-repo
    و در نصب متاسپلویت این پیغام
    E: Unable to locate package metasploit
    و در زدن msfconsole این پیغام
    msfconsole: command not found
    دلیل چیه؟!

    1. سلام، لطفا از آخرین نسخه نرم افزار استفاده کنید و دستورات را مو به مو کپی و پیست نمایید تا به مشکلی برخورد نکنید.

  5. من اخرین نسخه دانلود کردم و موبه موانجام دادم ولی بازم
    تویه نصبunstable-repo در آخر ارور میده و این پیغام رو میفرسته
    E: Unable to locate package unstable-repo
    و در نصب متاسپلویت این پیغام
    E: Unable to locate package metasploit
    و در زدن msfconsole این پیغام
    msfconsole: command not found
    دلیل چیه؟

    1. درود بر شما
      قبل از نصب و اجرای Metasploit بایستی مخازن ناپایدار (Unstable Repository) اضافه گردد که با دستور:
      pkg install unstable-repo
      قابل انجام است. در صورتی که قادر به نصب این بسته توسط دستور ذکر شده نیستید و به خطا برخورد نمودید ابتدا از یک VPN با آی پی خارج از کشور استفاده نموده و قبل از ادامه یکبار دستور زیر را اجرا کرده و مراحل را مجددا تست نمایید:
      pkg upgrade

دیدگاهتان را بنویسید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *